The Scene Editor

This window is the central place where you manage your scene. A CityEngine scene is organized in groups and layers. The following layer types exist:

The Scene Editor displays the current scene as a tree with group elements, layers, and objects.

Scenarios in the Scene Editor

See scenarios.

Working with Layers

Layers can easily be deleted, duplicated or merged by selecting the corresponding menu item from the context menu or the "Layer" menu in the main menu. In addition to that, you can use the standard cut, copy, and paste actions to transfer objects between layers.

The visibility of each layer in the viewport can be toggled by clicking the check box at the very right. You may re-arrange layers by dragging them to the desired position.

Note that the visibility of different object / layer types can also be controlled on a per-viewport basis from the view settings menu of a 3D viewport window.

Working with Group Layers

With group layers you can organize your work space by putting similar layers together based on similar geometry (i.e.buidings, blocks, street networks, models) or based on themes (i.e. elevation, imagery, terrain).

To create a New Layer Group, right-click inside the Scene Editor window and choose New→New Layer Group.

To add child layers or groups to the group you created, drag and drop them under the new group layer.

Colors

Each layer or group has a color state (colored or uncolored). When a layer doesn't have a color assigned to it, the color box displays grey-striped diagonal lines:

You can click on the color check box to assign a color to the layer or group. Click on the color check box again to remove the color.

To see how color behaves with parent and child layers, look at the examples below. The color is inherited from the group hierarchy. When you give a parent layer group a color, all child objects and models belonging to this layer or group will have that color in the Viewport. In the Scene Editor, the child layers will maintain their colors at all times.



Two colored layers with no inherited colors.



Two colored layers with inherited colors.

You can access the color value in the Scene Editor and in the Inspector.

Locking groups and layers

Each layer or group has a locked state (locked or unlocked). The middle check box displays the locked state on the same line of the layer in the Scene Editor. Once you lock a layer, you can't select or modify the corresponding objects.

When setting a group to "locked", the child layers and groups will keep their original locked state, but can't be selected.

The user can access the locked state in the Scene Editor and in the Inspector.

Visibility

Each layer or group has a visibility state (visible or invisible). A check box for the visibility state is displayed at the most right position on the same line of the layer (or group) in the scene editor. When disabling the visibility state, the corresponding objects will not be shown in the viewports, and can't be selected.

When a group is "invisible", the child layers and groups will keep their original visibility state, but their objects will not be displayed in the viewports.

The user can access the visibility state in the Scene Editor and in the Inspector.

Renaming layers and groups

It is possible to rename a layer or a group by two clicks on its name in the scene editor, or with the context menu ("Rename" entry)



Renaming an element.

Framing elements

A double click on any element in the Scene Editor frames the element in the viewports.

Multi selection

It is possible to select many layers/groups in the scene editor and to change visibility/lock/color state to all the selection

Using the Search Field to Select and Filter Objects

In the search field on the top of the scene window you can type a wildcard expression (e.g. "Lot*") to select matching objects.

Parameter Function
Shape* Matches scene objects whose names start with Shape
"Shape 12" Matches scene objects whose names are exactly Shape 12
Shape* *12 Matches scene objects whose names start with Shape AND end with 12

The search field allows the user to search for objects with name match, attribute match (name and value). The result of the the search is automatically selected and framed in the Viewport. The result of the search action is displayed in the status bar.

Whitespace characters in a search query denote a logical AND expression. To match object names with spaces, put your search query in double quotes ""

Importing and Exporting Layers

In the case where building lots or mass models have been already modeled with an external program, these can be imported as shape layers. First you have to convert your shapes into a grouped ".obj" file (each group corresponds one shape) or a ".dxf" file. Afterwards copy it into the data folder of your project and import it via File→Import→CityEngine Layers from the main menu or via the navigator context menu on the file. Afterwards the CGA shape grammar rules can be applied in the usual way on these imported shapes.

Any object from the scene window can be exported to a new scene by choosing
File→Export→Export Selected Objects as .cej File To import layers from the exported ".cej" file into a new scene, select File→Import→CityEngine Layers from the main menu.

 

 

 

Copyright ©2008-2017 Esri R&D Center Zurich. All rights reserved.