Scenarios in 3D views

You can perform a variety of actions with scenarios in the 3D View windows, such as choosing scenario layouts or and copying or moving objects to another scenario.

Choose scenario layout

Single scenario view (Default layout)

Click Window→Layout→Default.

2 Scenarios Side-by-side

Click Window→Layout→ 2 Scenarios Side-by-side.

3 Scenarios Side-by-side

Click Window→Layout→ 3 Scenarios Side-by-side.

Change active scenario

In each 3D scenario view you have the option to choose to display the active scenario set in the Scene Editor or a specific scenario.

The 3D View window displays the name and color of the scenario.

Modify scenario objects

The context menu in 3D views allows you to select objects in one scenario and perform actions to affect other scenarios. The context menu gives you different options for scenarios.

Copy objects to a scenario

You can copy objects from one scenario and add to another scenario. For example, you can copy objects from the North scenario to the South scenario.

  1. Select objects in the North scenario.
  2. Right-click Copy to scenario→South.


The objects are copied to South scenario and now exist in both the North and South scenarios.


Move objects to a scenario

You can move objects to another scenario. For example, you can move objects from the East scenario into the South scenario.

  1. Select objects in the East scenario.
  2. Right-click >Move to scenario→South.

The objects are moved to the South scenario and no longer exist in the East scenario.

Make default object

You can make an object a default object so that it belongs to all of the scenarios.

  1. Select buildings in the North scenario.
  2. Right-click Make default object.

The buildings are now default objects included in all the scenarios.

Remove from current scenario

You can remove objects from specific scenarios.

  1. Select buildings in the South scenario.
  2. Right-click Remove from current scenario.

The buildings are removed from the South scenario.

Create objects in scenarios with tools

You can create independent objects for each scenario with certain CityEngine tools. For example, you may have three scenarios, North, East, and West, and want to create a 3D model just in the East scenario. You would draw your 3D model only in the East scenario 3D View.

The street and shape creation tools also allow you to create specific objects per scenario.

Copyright ©2008-2018 Esri R&D Center Zurich. All rights reserved.