Importing Files into a Project

While dragging files form the file browser is convenient, importing a large number of files is cumbersome by dragging and dropping. CityEngine offers a wide range of import options for many common cases without the need to resort to external programs. Usually, a copy of a file is created inside your workspace. In a collaborative environment, an advanced option called "linking" can be used in order to share files and folder among team members.

You can either import files and folders directly from the file system as well as from an archive file. Archive files are the preferred way to exchange CityEngine projects since all project specific attributes will be preserved.

In order to import files into your project, select File→Import.

Select Files into Existing Project→File System and then click Next.

In the "From directory" field, type or browse to select the directory containing the files you wouldlike to import. Recent directories that have been imported from are shown on the "From directory" field's combo box.

In the right pane check the files and folders you wouldlike to import. Checking a folder in the left pane will import its entire contents into the workspace. A grayed checkbox indicates that only some of the files in the folder will be imported into the workspace.

The Filter Types button can be used to filter the types of files that will be imported.

The "Into folder" field should already be filled in with the name of the project you are working with but it can easily be changed with Browse.

In the Options area, options are given to:

Click Finish when done. The selected files and folders will appear in the Navigator.

If your files are located in a zip or tar archive, choose Select Files into Existing Project→Archive File and then click Next.

The following options are available for an archive file import:

Copyright ©2008-2016 Esri R&D Center Zurich. All rights reserved.