Working with the Model Hierarchy Explorer

The shape tree of a generated model can be interactively explored. To open the Model Hierarchy Explorer, select Window → Show Model Hierarchy from the menu:

Shape Tree Explorer A
The Model HierarchyExplorer can be opened in the Window menu.

Generate a model, select it and hit the Inspect Model tool button in the toolbar of the model hierarchy:

Shape Tree Explorer B
A generated model can be switched to the edit model; its hierarchy then appears in the Model Hierarchy Explorer.

The model hierarchy (or shape tree) of a model can now be unfolded by clicking on nodes or using the context menu (right-click) on a tree node:

Shape Tree Explorer
Use the right-click menu to expand and collapse model hierarchy nodes.

The shape tree of a specific building is defined by the associated rule file and the initial shape. Double-click on a node or choose Jump to rule in the context menu to jump to the respective rule in the rule file.

Shape Tree Explorer
Part of a CGA rule file and the hierarchy of the generated model.

The pictures above show snippets from the Candler rule file (which can be found in the Tutorials). Note the matching structures (Footprint → Solid → FrontFacade/RearFacade/SideFacade/Roof) in the rule file and the model hierarchy.

Each node of the model hierarchy can be expanded and collapsed using the right-click menu. Moreover, each shape node can be selected/deselected with a left click (use the ctrl modifier to select more than one node). A number of special rendering modes are available to show the attributes of the selected shapes. It is also possible to directly click into the model in the 3D Viewport:

Shape Tree Explorer
Using the special rendering modes to visualize attributes of the selected shape tree nodes.

Let us look at the toolbar switches in more detail:

Toolbar

Button Description
Inspect model tool Activate inspect model mode.
Transparent model Set the drawing mode of the selected model to transparent.
Translucent model Set the drawing mode of the selected model to translucent.
Opaque model Set the drawing mode of the selected model to opaque.
Show scope The selected shape nodes' scopes are drawn (x-axis red, y-axis green, z-axis blue, other scope edges orange).
Show pivot The selected shape nodes' pivots are drawn (x-axis red, y-axis green, z-axis blue).
Show geometry The selected shape nodes' geometry attribute is drawn.
Show trim planes The selected shape nodes' trim planes are drawn.
Show origin of model Tthe model's origin is drawn (x-axis red, y-axis green, z-axis blue).
Frame selection The selected nodes in the model hierarchy view are framed.
Zoom in Zoom in the shape tree structure in the model hierarchy view.
Zoom out Zoom out the shape tree structure in the model hierarchy view.

The size and and line width of scopes, pivots and trim planes can be set in Edit → Preferences → General → Procedural Runtime → Display Options.

Copyright ©2008-2017 Esri R&D Center Zurich. All rights reserved.